Instal Metasploit Ubuntu

Metasploit adalah alat lintas platform dan sumber terbuka yang awalnya dikembangkan oleh HD Moore pada tahun 2003. Ini ditulis dalam Ruby dan tersedia untuk Windows, MacOS, dan Linux. Metasploit biasanya digunakan untuk pengujian dan penelitian keamanan ofensif. Ini digunakan untuk tujuan berikut:

  • Penilaian Kerentanan dan Pentesting
  • Pengembangan tanda tangan IDS
  • Eksploitasi pengembangan dan penelitian

Rilis Metasploit utama terbaru telah memindahkan intinya ke semua basis pemrograman Ruby. Metasploit-framework menggunakan Ruby sebagai bahasa pemrograman intinya karena Ruby adalah bahasa interpretasi yang kuat. Proyek Metasploit sangat terkenal karena fitur anti-forensik dan penghindaran deteksinya.

Metasploit umumnya menawarkan versi komunitas dan open source dari Metasploit Framework tetapi juga memiliki versi komersial seperti Metasploit Pro dan Metasploit Express. Ia juga memiliki database shellcode, shellcode ini dapat digunakan untuk melakukan shell terbalik ke engine penyerang.

Seperti produk sejenis lainnya seperti Canvas atau Core Impact dan produk keamanan komersial lainnya, Metasploit-Framework dapat digunakan untuk memeriksa keamanan sistem komputer atau untuk membobol jaringan dan sistem. Mirip dengan banyak alat keamanan lainnya, Metasploit Framework dapat digunakan untuk aktivitas yang sah dan tidak sah.

Ikuti langkah-langkah di bawah ini untuk menginstal Metasploit Framework di OS Ubuntu Anda

Related Posts